We have resolved the issue causing the timeouts and delays on the Integrations page and Saved Query Automations.
Posted Jan 29, 2026 - 09:50 EST
Monitoring
The Censys Engineering team has restored full functionality to Integrations and Saved Query Automation pages. We're monitoring overnight to ensure no regression.
Posted Jan 27, 2026 - 21:53 EST
Identified
Our Engineering team has identified the issue impacting the Integrations and Saved Query Automation pages in ASM and is actively working toward a resolution. We will provide an update as more information becomes available.
Posted Jan 27, 2026 - 15:32 EST
Investigating
We are currently experiencing timeouts and delays on the Integrations and Saved Query Automation pages in ASM. Our team is actively investigating the issue and working to restore normal performance as quickly as possible. We will update the status page when more information is available.
Posted Jan 27, 2026 - 14:53 EST
This incident affected: Censys ASM (Inventory Search, Integrations).