Censys Search Team Invite Links Returning 404 Error

Incident Report for Censys

Resolved

Our Engineering team has fixed the issue that caused invited users to encounter a 404 error when clicking Censys Search Team invitation links. All newly generated invite links are now working as expected.
Posted Aug 08, 2025 - 09:10 EDT

Identified

Users invited to a Censys Search Team are currently encountering a 404 error when clicking the invitation link in their email. This issue affects all newly generated Search Team invite links.

We have identified the problem and are actively working on a fix.

We will update this status page as soon as more information becomes available or once a fix has been deployed.
Posted Aug 06, 2025 - 18:08 EDT
This incident affected: Censys Search (WebUI).