Degraded Performance – Collections Not Updating

Incident Report for Censys

Resolved

The issue affecting Collections updates has been resolved. Assets are updating as expected.
Posted Oct 21, 2025 - 08:59 EDT

Identified

Collections are currently not updating with added or removed assets due to an ongoing issue with a vendor that depends on AWS. Censys Engineering is monitoring the issue.
Posted Oct 20, 2025 - 16:40 EDT
This incident affected: Censys Platform (Censys Platform Web UI).