Censys Engineering has confirmed that no issues linger from the incident. All services are operating as expected.
We thank you for your patience while we worked on resolving the issue.
Posted Aug 25, 2026 - 09:52 EDT
Monitoring
Censys Engineering has deployed another fix to alleviate the login slowness. All systems appear to be working as expected, though we will continue to monitor.
Posted Aug 24, 2026 - 17:26 EDT
Identified
Censys Engineering has identified additional contention now causing login delays. A fix is being worked on.
Posted Aug 24, 2026 - 16:04 EDT
Monitoring
Censys Engineering has implemented a fix for the 500 errors that were showing up. We're continuing to monitor throughout the afternoon.
Posted Aug 24, 2026 - 14:11 EDT
Investigating
Censys Engineering is investing intermittent 500s when searching Platform.
Posted Aug 24, 2026 - 13:52 EDT
This incident affected: Censys Platform (Censys Platform Web UI, Accounts Web UI).