Censys Engineering has identified the underlying cause of the issue and has restored service. Slowness in the UI is still expected while we continue to work on restoring full operation of our underlying systems.
Posted Oct 02, 2025 - 14:14 EDT
Update
We have identified that the issue also impacts API endpoints for host lookups. Users may experience degraded performance, timeouts, or errors when making API requests. Our engineering team is continuing to investigate and will provide updates as more information becomes available.
Posted Oct 02, 2025 - 13:48 EDT
Investigating
Censys Engineering is investigating timeouts and errors affecting host detail pages in Censys Search and the Censys Platform. Users may experience slow load times or error messages when accessing these pages.
Posted Oct 02, 2025 - 13:28 EDT
This incident affected: Censys Platform (Censys Platform Web UI, API) and Censys Search (Search API - Lookup Endpoints, WebUI).