Asset details performance degradation

Incident Report for Censys

Resolved

Asset details performance issues have been resolved.
Posted Jul 17, 2026 - 09:14 EDT

Monitoring

We have implemented changes to address the performance issues and are now monitoring asset detail performance.
Posted Jul 16, 2026 - 15:11 EDT

Investigating

We are looking into a degradation of performance when fetching asset details.
Posted Jul 16, 2026 - 11:21 EDT