Recent UIDS Avro snapshots are corrupted
Incident Report for Censys
Resolved
Our Engineering team has rebuilt the 3 snapshots that were impacted. They are currently available, and the 2 corrupted fields were removed.
Posted Feb 23, 2024 - 15:40 EST
Identified
Some Avro deserializers may not be able to parse the snapshot files for the following dates: 2024-02-20, 2024-02-21 and 2024-02-22

The following data fields are corrupt in those snapshots (in both BigQuery and Data Downloads):
location.continent
location.country

Our current plan:
We are immediately fixing the bug and ensuring that tomorrow's snapshot is not affected by the corruption issue. This will be snapshot date 2024-02-23.
Tomorrow, we will drop those corrupted fields from our dataset for those 3 days, and regenerate the downloadable files.
This means that the 3 snapshot dates listed above will permanently be missing those 2 fields.
Posted Feb 22, 2024 - 15:55 EST
This incident affected: Censys Data (UIDS).