Inventory updates are delayed

Incident Report for Censys

Resolved

Attack Surface Management inventory is now updated. Discovery and Association processes will resume at their regularly scheduled intervals.
Posted May 09, 2026 - 00:03 EDT

Monitoring

Censys Engineering has mitigated the issue causing Attack Surface Management inventory updates from association and discovery to be delayed.
We are monitoring jobs and expect that all inventory updates will land within ~5 hours.
Posted May 08, 2026 - 15:39 EDT

Investigating

Censys Engineering has detected an issue that will result in Attack Surface Management inventory updates from association and discovery being delayed. We are actively investigating the underlying cause.
Posted May 08, 2026 - 14:14 EDT
This incident affected: Censys ASM (Discovery, Association).