The missing virtual hosts snapshots has posted to the Censys Data Downloads API. This incident is resolved.
Posted May 07, 2026 - 07:15 EDT
Update
The snapshot upload is continuing. The virtual hosts snapshot should become available to customers overnight.
Posted May 06, 2026 - 21:49 EDT
Monitoring
The replacement snapshot for 2026-05-05 has completed and is being uploaded to our cloud storage for customer access. We will update here once the snapshot is available.
Posted May 06, 2026 - 17:18 EDT
Update
Censys Engineering is making forward progress on a mitigation for the underlying cause of the missed snapshot. We hope to be able to begin building the final snapshot within the next few hours.
Posted May 06, 2026 - 15:02 EDT
Identified
The underlying cause of the missed snapshot has been identified. The engineering team continues to work toward a resolution.
Posted May 06, 2026 - 11:48 EDT
Investigating
The virtual hosts snapshot for 2026-05-05 for Censys Data Downloads customers is delayed. Censys Engineering is investigating. We will update this status page when we have more information on when to expect the snapshot.
Other datasets generated as usual for 2026-05-05. Only virtual hosts was affected.