The Censys Platform is periodically returning 502s

Incident Report for Censys

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 19:21 EDT

Investigating

The Censys Platform is periodically returning 502 errors and is impacting the UI and API. Our Engineering team is currently investigating and will update the status page when more information is available.
Posted Mar 17, 2025 - 18:24 EDT
This incident affected: Censys Platform (Censys Platform Web UI, API).