Historical data calls are timing out

Incident Report for Censys

Resolved

This incident has been resolved. Censys Platform is operating normally.
Posted Sep 18, 2026 - 15:59 EDT

Monitoring

Censys Engineering has identified the issue and impact has been contained. We are continuing to investigate the underlying causes.
Posted Sep 18, 2026 - 15:40 EDT

Investigating

API calls and UI calls that attempt to retrieve historical data are timing out. Censys Engineering is investigating the underlying cause.
Posted Sep 18, 2026 - 14:51 EDT
This incident affected: Censys Platform (Censys Platform Web UI, API).