Delayed ASM Asset Inventory Updates

Incident Report for Censys

Resolved

All workspaces have been updated.
Posted Jun 04, 2026 - 09:40 EDT

Monitoring

We are currently experiencing delays in ASM asset updates. The underlying issue has been identified and resolved, and processing has resumed.

However, a significant backlog accumulated while the issue was active. As a result, asset updates may continue to be delayed for several hours as we work through the backlog and return processing to normal levels.

No data has been lost, and queued updates will be processed automatically. We are actively monitoring recovery progress and will provide additional updates as the backlog decreases.
Posted Jun 03, 2026 - 12:11 EDT
This incident affected: Censys ASM (Association).