Cloud Connector Asset Cleanup Delay

Incident Report for Censys

Monitoring

We identified a scaling issue that caused a backlog in the cleanup of outdated cloud connector assets in some workspaces. Configuration changes have been applied and the system is now actively processing and removing stale assets. We are also working on additional cleanup for orphaned assets. We will continue monitoring and validate system health across all workspaces on Monday, and will update the status page when more information is available.
Posted Jan 30, 2026 - 14:56 EST

Investigating

We are investigating an issue affecting the cleanup of outdated cloud connector assets in some workspaces. Our team is actively working to identify the cause and restore normal behavior. We’ll provide updates as more information becomes available.
Posted Jan 29, 2026 - 12:25 EST
This incident affects: Censys ASM (Inventory Search).